JBOSS:Java版本不正确而导致的JBoss无法正常启动

By | 2014年7月11日

如标题所示,有时候在你启动JBOSS的时候,会卡在“JBAS015899: JBoss AS 7.1.1.Final “Brontes” starting”的阶段,无法继续。
它的具体呈现如下:

如上所示,除非强行中断(Ctrl + c),否则会永久的卡在那里。
——————————————————————————————————————————————————————
这个问题,实际上是由于当前系统的Java版本不适应而引发的。
(反馈信息“Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0”)
发生上述情况的时候,我的Java版本为:1.8。

当更换Java版本为1.7后,问题就解决了。(JBOSS的启动恢复正常)

正常情况下,JBOSS的启动脚本的输出如下:

—————————————————————————————————————————————
Ending。

打赏

说点什么

1 评论 在 "JBOSS:Java版本不正确而导致的JBoss无法正常启动"

提醒
avatar
mumu
游客

请问 是不是 jboss7 不支持jdk8???

wpDiscuz