默认情况下,MS Windows server 2008 R2,安装好了以后,PowerShell的版本是V2:

因此,如果想要使用最新的PowerShell,你需要执行升级操作。

当前最新版本的PowerShell是:5.1

一、.NET Framework 4.6支持
该版本的安装,需要.NET Framework 4.6的支持:
WMF 5.1 Preview requires the .Net Framework 4.6

.NET Framework 4.6的官方离线包下载地址:
https://www.microsoft.com/en-US/download/details.aspx?id=53344

安装好了.NET Framework 4.6以后,你还需要安装WMF。

.NET Framework的安装,官方有支持文档(各个版本的下载路径):
https://msdn.microsoft.com/en-us/library/5a4x27ek(v=vs.110).aspx

二、Windows Management Framework支持

WMF的安装,官方有支持文档(各个版本的下载路径):
https://msdn.microsoft.com/en-us/powershell/wmf/5.1/install-configure

WMF 5.0:
https://www.microsoft.com/en-us/download/details.aspx?id=50395

三、升级完成:
上面的安装完成后,会要求重启电脑。

电脑重启好了以后,你会发现PowerShell已经升级成功:

——————————
Done。

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

隐藏
变装