如果你是在Linux中安装Oracle,你可能遇到如下图所示的问题:
oracler_OUI_error
可以看到,安装进程卡在了17%的位置,无法继续。

通过查看后台的安装日志,你可以发现问题所在:

该问题是由于Linux内核版本与Oracle database 9i要求的内核版本不匹配造成的。
在内核版本不匹配时,最好的办法是使用适应的操作系统版本。

或者你可以尝试使用以下的方式修正:
解决方法是声明环境变量:LD_ASSUME_KERNEL,让OUI回避上述问题。
具体操作如下:
一:

二:

第二种方法成立的原因是:
about_LD_ASSUME_KERNEL

另一个造成上述问题的原因是:
你在64位操作系统上安装32位的介质,或者反之亦然。
解法显而易见:更换正确的安装介质。
————————————————
Ending。

1 thought on “Oracle Database 9i:Install on RHEL5 64,卡在17%的位置”

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

隐藏
变装