Linux的操作系统在装好后,默认会带Python2的支持。
但是,并没有包含PIP的支持。

因此,PIP需要自行安装。

但是,如果你的Python是2的版本,你想要安装PIP,直接运行【get-pip.py】很可能会遇到各种问题:
1. http://d-prototype.com/archives/13663
2. http://d-prototype.com/archives/13664

正确的做法是,下载对应的Python版本的【get-pip.py】的脚本。

如果你觉得这个过程很烦,.. 那么你可以用我的脚本自动的去安装:

脚本执行效果如下:

为了演示,Linux先卸载PIP:

卸载后,查看:

PyCharm,运行Python自动安装Pip的程序:

Linux,检查安装后的状态:

可以看到,通过Python自动安装PIP,成功。

————————————————————

Python代码,项目资源视图:

脚本代码如下:

————————————
Done。

说点什么

avatar

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据

  Subscribe  
提醒